+7 (495) 369-14-12
Пн - Пт, 10:00 - 20:00 мск
Главная » Документация » UVScreenCamera » Видео редактор

Редактирование видео


После записи фильма можно вырезать лишние куски, добавить паузы, если нужно, наложить звук. Для наглядности можно добавить поясняющие выноски, рамки, картинки.

Видео редактор

Добавление элементов (выносок, картинок, ...)

Пункт меню "Вставка объекта" или соответствующая кнопка на верхней панели. Если текущий слой занят другим элементом, то создается новый слой. Для настройки параметров каждого элемента нажмите кнопку "Свойства" или выберите соответствующий пункт из контекстного меню. Элементы можно перемещать по временной шкале, менять длительность отображения на экране, переносить с одного слоя на другой.

Примечание:

  • Порядок слоев снизу-вверх.
  • Элементы добавляются в текущий кадр
  • Очень полезен бывает пункт меню "Редактирование", где можно указать начало и длительность отображения для выделенных объектов

Тень у объектов

В новой версии у большинства видимых объектов появилось свойство Тень.
Во многих случаях объекты с тенью лучше выделяются на фоне изображения и выглядят более привлекательно.

Выравнивание объектов

Часто требуется выровнить объекты в кадре.

  • По левому краю, центру и т.д. (и аналогично по вертикали)
  • Ровно друг под другом
  • Сделать одинаковой ширины, высоты
  • Расположить на одинаковом расстоянии
  • Во всю ширину или высоту кадра

Все это делает изображение в кадре более аккуратным и профессиональным.
Вручную это делается долго. Теперь для этого есть специальный инструмент.

Меню Выравнивание.

И специальная панель.

Можно выравнивать сразу группу выделенных объектов.

Список всех объектов

Для облегчения навигации по длительным видео записям добавлен список всех объектов.
Вызывать список можно из меню Навигация, "Все объекты".

По двойному клику на объекте редактор перейдет на кадр, в котором есть этот объект.
Слева есть фильтр для облегчения поиска нужно объекта. Чаще всего используется текст выноски.

Выделение кадров

Появился новый удобный инструмент для выделения кадров. Посмотрите флэш-ролик.


Как и раньше, кадры можно выделять, используя панель кадров. Проведите мышью под номерами кадров. Можно щелкнуть на одном кадре, затем с Shift-ом на другом кадре. Выделится диапазон между этими кадрами.

Выделяем кадры

Добавление, удаление, копирование кадров

Пункт меню "Кадры / Добавить кадры". Пока можно добавить только копию текущего кадра. Это нужно для создания паузы в фильме. В дальнейшем планируется добавить эффекты перехода из одного кадра в другой.

Кадры не удаляются сразу. Они помечаются на удаление. Можно посмотреть что получится после удаления выделенных кадров в предварительном просмотре. В любой момент кадры можно вернуть, сняв отметку об удалении.

Кадры помеченные на удаление

Для того чтобы окончательно удалить кадры из проекта (без возможности восстановления) используйте пункт меню "удалить кадры, помеченные на удаление".

Кадры, как обычные объекты, можно копировать и вставлять в проект (Ctrl+C, Ctrl+V).

Метки кадров

Метки очень помогают в навигации по фильму. Создать метку можно из пункта меню "Кадр", "Редактировать метку кадра". После создания метки рядом с кадром появится значок @. Можно перемещаться по меткам с помощью кнопок "Ctrl + влево", "Ctrl + вправо", а также с помощью пункта меню "Навигация".

Метки служат также для разделения фильма на отдельные сегменты при экспорте в SWF, UVF, EXE.

Примечание:
Следует запомнить очень полезные для навигации сочетания клавиш: "Ctrl + влево", "Ctrl + вправо", Home, End, PageUp, PageDown.

Сглаживание движения курсора

Нередко проект пишется частями. На границе этих частей курсор "дергается", потому что в конце записи первой части и начале записи второй находится в разных точках. И чем больше расстояние между этими точками, тем сильнее это "скачок" курсора на границе. Теперь есть функция для сглаживания движения курсора. Выделяем диапазон кадров в которых нужно сгладить движение курсора и выбираем "Редактирование / Сгладить движение курсора". Как правило, достаточно выделить 5-10 кадров.

Наложение звука

Наложение звукового сопровождения лучше делать в последнюю очередь, чтобы не нарушать синхронизацию звука и видео. Звук можно записать с колонок или микрофона либо импортировать из файла (*.wav, *.mp3).

Окно наложения звука

Разделение звука на части

Звуковые объекты разделяются по текущему кадру. Порядок действий:

  1. Установите указатель текущего кадра в нужное положение
  2. Выделите звуковые объекты, которые необходимо разделить (чтобы выделить несколько объектов, удерживайте Ctrl)
  3. Выберите "Редактирование / Разделить звук" или соответствующий пункт из контекстного меню.
В результате получится два независимых объекта.

Примечание:
Если выделить не звуковые объекты, то данная функция будет недоступна.

Переименование проекта

Проект представляет собой отдельную папку с файлом *.upr. Имена проектам (и папке и файлу) присваиваются автоматически. Чтобы не путаться в своих проектах, лучше присвоить проекту понятное имя. Пункт меню "Файл", "Переименовать проект".

Если на компьютере не было старых версий UVScreenCamera, то все проекты хранятся в "Мои Документы\uvSC_Projects". Иначе в "Program Files\UVsoftium\UVScreenCamera\Projects". Каталог для проектов можно поменять в настройках.

Импорт фильмов UVF

В редактор можно импортировать фильмы, записанные с помощью предыдущих версий UVScreenCamera: либо открыть файл из главного окна и затем нажать "Редактор", либо прямо из редактора "Файл", "Импорт".

Примечание:
Импорт может занять довольно продолжительное время (т.к. происходит преобразование форматов).

Экспорт фильмов

"Файл", "Экспорт". Откроется мастер экспорта фильма. Часть форматов для экспорта доступна только после регистрации.